Note: This page is no longer being maintained and is kept for archival purposes only.
For current information see our main page.
PlantStudio Kurtz-Fernhout Software
Developers of custom software and educational simulations.
Home ... News ... Products ... Download ... Order ... Support ... Consulting ... Company
Product area
Help System
Quick Tour
How it works
Making a Paint Shop Pro Picture Tube

Paint Shop Pro has a Picture Tube brush (in versions 5.0 and up) that allows you to "spray" a bitmap with pictures of plants. Paint Shop Pro uses "tube files" to store the bitmaps you paint with. PlantStudio can help you create Paint Shop Pro picture tubes from your plants.

The process of making Paint Shop Pro picture tubes from PlantStudio plants is not completely automated and requires some knowledge of Paint Shop Pro. Also, we may not have all these instructions correct for your version of Paint Shop Pro. If any of our instructions don't make sense in Paint Shop Pro, check your Paint Shop Pro documentation for help.

Step 1: Make the picture tube bitmap file in PlantStudio
Select the plants you want to include in your picture tube in the PlantStudio main window.
gif/plantstudio00090000.gif Choose Save Nozzle/Tube Bitmap from the File menu. The Save Nozzle/Tube Bitmap window will appear.
gif/plantstudio00090000.gif First choose which plants you want to use in the tube -- the ones you already selected, or all visible plants, or all the plants in the open plant file.
gif/plantstudio00090000.gif Choose 24-bit color depth, because Paint Shop Pro requires it for picture tubes.
gif/plantstudio00090000.gif Choose a resolution. Pay attention to the file size reported at the bottom of the window.
gif/plantstudio00090000.gif Choose a background color to draw behind the plants. Normally you will want to leave this color as black, because you need a color you don't find in any of your plants. If you have any black parts in your plants you can change this to a color you don't have, like white.
gif/plantstudio00090000.gif At the bottom of the window you can see the number of items and the tube cell size. You need to remember the number of items, but Paint Shop Pro calculates the cell size itself.
gif/plantstudio00090000.gif Click Save, then choose a directory to place the bitmap file in. The file will be called "nozzle" something, but this doesn't mean you can't use the file in Paint Shop Pro -- it just means Painter had its nozzles before Paint Shop Pro had its picture tubes. You can change the file name if you like because Paint Shop Pro doesn't need all that information (Painter does).

Step 2: Select the plants in Paint Shop Pro and clear the background
Start Paint Shop Pro and open the bitmap file you just saved.
gif/plantstudio00090000.gif Click the Magic Wand button on the toolbar.
gif/plantstudio00090000.gif Click anywhere there isn't a plant. You should see the entire non-plant area of the bitmap selected. See the tips below and Paint Shop Pro's help system if you are having trouble getting a clean selection.
gif/plantstudio00090000.gif Choose Invert from the Selections menu. Now only the plants should be selected.
gif/plantstudio00090000.gif Choose Promote to Layer from the Selections menu to make the selection into a layer. (If you did not save the file in 24-bit color, this menu item will be unavailable. Choose 16 million colors (24 bit) from the Colors menu.)
gif/plantstudio00090000.gif Now open the layers palette if it is not open (choose Toolbars from the View menu, then check Layer Palette in the list).
gif/plantstudio00090000.gif In the layers palette, click on Background.
gif/plantstudio00090000.gif Choose Delete from the Layers menu. The background color will disappear and you should see the plants against a transparent (checkerboard) background. This is your picture tube.

Step 3: Save the picture tube
Now choose Export -- Picture Tube from the File menu. In the window that appears, enter the number of plants in the Cells Across edit box. If you forgot how many plants there were, just count the plants in the picture you see. If you enter the wrong number of plants you might get a tube with fragments of plants. But don't worry -- Paint Shop Pro lets you change this information later.
gif/plantstudio00090000.gif Enter a name for your new tube and click OK.
gif/plantstudio00090000.gif You can close the tube file now.

Step 4: Use the tube
Create a new image with nothing in it.
gif/plantstudio00090000.gif Choose the Picture Tube button on the toolbar.
gif/plantstudio00090000.gif Bring up the controls palette (choose Toolbars from the View menu, then check Control Palette in the list).
gif/plantstudio00090000.gif In the controls palette, choose your tube from the drop-down list.
gif/plantstudio00090000.gif Start drawing with the tube in your picture.
gif/plantstudio00090000.gif If the plants are fragmented, click Options on the controls palette and change the number labeled Cells Across to the correct number of plants.

Tips on making and using picture tubes
You can change how large or small the plants come out in Paint Shop Pro by changing the Scale slider on the controls palette.
gif/plantstudio00090000.gif If your plants are fairly large (say 100x100 pixels), laying down the plant pictures with mouse movement may be sluggish in Paint Shop Pro. If you want your plants to appear large, it's best to click for each plant instead of dragging. Reducing the scale also solves this problem.
gif/plantstudio00090000.gif If your plants come out with pieces of the background color between some leaves, you might have to merge together two or more magic wand areas when you do the initial selection for the tube. To do this, check the Sample Merged checkbox on the controls palette while you are using the magic wand, then Shift-click on the different internal areas you want to include in your selection. When you have included all the background color areas you can find, then invert the selection and proceed as usual. If this is really messy, you can avoid the problem by going back to PlantStudio and rotating the plants in question until you don't see as many isolated areas of background color.
gif/plantstudio00090000.gif To get rid of a tube, you need to remove the lines that describe the tube file from the text file Tubes.ctl in the Tubes directory under Paint Shop Pro 5. See your Paint Shop Pro help system for help with this.
gif/plantstudio00090000.gif If you distribute a picture tube over the internet, it's a good idea to include a text file that has the lines that must be inserted in the Tubes.ctl file (with an explanation of how to do it) so anyone who downloads your tube can use it easily.

Home ... News ... Products ... Download ... Order ... Support ... Consulting ... Company
Updated: March 10, 1999. Questions/comments on site to
Copyright © 1998, 1999 Paul D. Fernhout & Cynthia F. Kurtz.